Domino Puzzle

Domino Puzzle is a simple tile game where you have to arrange twelve dominoes on the board.

Please also read the license agreement.

Copyright
© 2002-2003 Arbeitskreis Spielkultur

Programming
Guido Stammel

All product and company names used in this documentation might be registered trademarks of their respective owners and are acknowledged without special markings.


License Agreement

NOTE: This is a translation of our license agreement into English. This translation is distributed in the hope that it will facilitate understanding, but it is not an official or legally approved translation. This translation is not official. Legally speaking, the original (German) version of the license agreement is what specifies the actual distribution terms for Spielkultur programs.

Important notice:

Please read the following license agreement carefully. By installing, copying or by any other means using these products, you confirm that you have read this license agreement and that you are obliged to follow the conditions stated in this license. In case you do not comply to the above said, you are not allowed to use any of the products.

A. License:

  1. "Arbeitskreis Spielkultur" (hereafter referred to as "Spielkultur") provides you with media storage or gives you access to media storage free of charge. These storages contain data (hereafter referred to as "the product") in the form of a computer program, computer software including source codes, objects including their application programming interfaces (API), furthermore pictures, forms (templates) and texts. The above mentioned forms of data are integrated into the software and the provided written accompanying material. This furthermore includes a license agreement and "online" (or electronical) documentation.
  2. Spielkultur grants you the right of user (the license) of the products after the following regulations of this contract. The copyright and all other rights to the product remain at the hands of Spielkultur.
  3. All additional software source codes and supplementals, provided by Spielkultur as a part of Spielkultur's product support are seen as a part of the product itself and underly the regulations of this license.

B. What you are allowed to do:

  1. Spielkultur grants you the single but not exclusive right of user of the product.
  2. You are allowed to install and use copies of the product on as many computers and systems as you wish. Furthermore you are allowed to make copies for archiving or backup purposes. You are also allowed to make copies for private and free-of-charge distribution to third parties, and are allowed to distribute these copies in private and free-of charge to third parties.

C. What you are NOT allowed to do:

  1. You are not allowed to use the product in any way that not explicitly allowed by this license, and to make copies that are not explicitly allowed by this license.
  2. Spielkultur especially prohibits the compilation or decompilation or re-engineering, as well as the temporal limited and/or charged distribution of the product or parts of the product. The product must not be changed or altered in subject or contents or linked/bundled in parts or as a whole with another product. You are not allowed to distribute the product for commercial use, even not if this happens free-of-charge. You are not allowed to distribute the product through a website.

D. Termination:

  1. This license stays effective as long as you adhere to the regulations of this license. The license automatically terminates in the case of the violation of any term or regulation of this license. Upon termination you must delete all copies of the product. The following terms of warranty also stay effective after a termination.

E. Exclusion of liability:

  1. Spielkultur only takes responsibility for malice afore-thought, fraud and gross negligence, but not for light and moderate negligence.
  2. This exclusion of liability is applicable to the software and to the storage media.
  3. This exclusion of liability is furthermore applicable to all contractual, legal and other claims, especially for general, indirect or consequential damages done to other objects, lost data and financial loss.

F. General terms:

  1. This license contains all agreements between you and Spielkultur and replaces all other agreements, either in verbal or written form. This license can only be changed by a signed agreement.
  2. This license underlies the right of the Federal Republic of Germany (Bundesrepublik Deutschland) and is applied in conjuction with german right, by exclusion of the german international private rights (Internationalen Privatrecht), and by exclusion of the agreement of the United Nations concerning the international treaty (Abkommen über den Internationalen Warenkauf) and any other applicable laws executing this international agreement.
  3. Should any one or more of these terms or regulations get or be invalid, it or they will be replaced by a legal term most fitting to the original intention. The invalidity of a regulation does not affect the validity of the other terms of this license. They remain effective.


Lizenzvereinbarung

Wichtiger Hinweis:
Lesen Sie sich diese Lizenzvereinbarung vor Benutzung des Produktes sorgfältig durch. Durch die Installation, das Kopieren oder eine anderweitige Nutzung dieses Produktes bestätigen Sie, dass Sie diese Lizenz gelesen haben und verpflichtet sind, die in dieser Lizenz enthaltenen Bedingungen einzuhalten. Sind Sie nicht damit einverstanden, so entfällt jegliche Nutzungsberechtigung des Produktes.

A. Lizenz:
(1) Spielkultur stellt Ihnen unentgeltlich Speichermedien oder den Zugang zu Speichermedien zur Verfügung, die Daten (im Folgenden: das "Produkt") in Form eines Computerprogramms, Computersoftware einschließlich Code, Objekten einschließlich deren Anwendungsprogramm- Schnittstellen, sowie Bildern, Bildschirmformularen (Templates) und Text enthalten, die in die Software und das schriftliche Begleitmaterial integriert sind; zudem einen Lizenzvertrag sowie "Online"- oder elektronische Dokumentation.
(2) Spielkultur gewährt Ihnen ein Nutzungsrecht (die Lizenz) zur Nutzung des Produktes nach Maßgabe der nachfolgenden Bestimmungen dieses Vertrages. Die Urheberrechte und sämtliche sonstigen Rechte an dem Produkt verbleiben bei Spielkultur.
(3) Sämtliche zusätzlichen Software-Codes und Unterstützungsmaterialien, die Ihnen von Spielkultur als Teil von Spielkulturs Supportleistungen für das Produkt zur Verfügung gestellt werden, gelten als Teil des Produkts und unterliegen den Bestimmungen dieser Lizenz.

B. Was Sie dürfen:
(1) Spielkultur gewährt Ihnen das einfache, nicht ausschließliche Nutzungsrecht an dem Produkt.
(2) Sie dürfen Kopien des Produktes auf beliebig vielen Computern installieren und benutzen. Ferner dürfen Kopien des Produktes für Archivierungs- und Sicherungszwecke, sowie für die unentgeltliche Weitergabe an Dritte im privaten Bereich erstellen, und diese unentgeltlich an Dritte im privaten Bereich weitergeben.

C. Was Sie nicht dürfen:
(1) Sie dürfen das Produkt nicht auf eine Weise benutzen, die nicht durch diese Lizenz ausdrücklich erlaubt ist, und keine Kopien erstellen, die nicht durch diese Lizenz ausdrücklich erlaubt sind.
(2) Insbesondere ist das Übersetzen, Dekompilieren oder Rückübersetzen sowie die zeitlich beschränkte und/oder entgeltliche Weitergabe des Produktes oder auch von Teilen des Produktes untersagt. Das Produkt darf nicht sachlich oder inhaltlich verändert oder ganz oder teilweise mit einem anderen Produkt zusammenfügt werden. Sie dürfen das Produkt nicht im geschäftlichen, beruflichen oder gewerblichen Bereich weitergeben, selbst dann nicht, wenn dies unentgeltlich geschieht. Sie dürfen das Produkt nicht über eine Website verbreiten.

D. Laufzeit:
Diese Lizenz bleibt nur solange wirksam, wie Sie die Bestimmungen dieser Vereinbarung einhalten. Sie endet automatisch in dem Fall, daß Sie irgendeine Bestimmung dieser Vereinbarung nicht einhalten. Sie verpflichten sich, bei einer Beendigung sämtliche Kopien des Produkts zu vernichten. Nachstehend dargelegte Beschränkungen der Gewährleistung und Haftung bleiben auch nach einer Beendigung in Kraft.

E. Beschränkungen der Gewährleistung und Haftung:
(1) Spielkultur haftet nur für Vorsatz, grobe Fahrlässigkeit und Arglist; jedoch nicht für leichte und mittlere Fahrlässigkeit.
(2) Diese Haftungsbeschränkung gilt sowohl für die Software als auch für die Speichermedien.
(3) Diese Haftungsbeschränkung gilt für alle vertraglichen, gesetzlichen und sonstigen Ansprüche, insbesondere auch für Schäden, die an anderen Gegenständen entstehen, verlorene Daten, mittelbare Schäden, Folgeschäden oder entgangenen Gewinn.

F. Allgemeines:
(1) Diese Lizenz stellt die gesamten Vereinbarungen zwischen Ihnen und Spielkultur dar und ersetzt jegliche sonstigen mündlichen oder schriftlichen Vereinbarungen oder Absprachen. Diese Lizenz kann nur durch eine unterzeichnete Vereinbarung geändert werden.
(2) Diese Lizenz unterliegt dem Recht der Bundesrepublik Deutschland und wird in Übereinstimmung mit dem deutschen Recht ausgelegt, unter Ausschluß des deutschen Internationalen Privatrechts, sowie unter Ausschluß des Übereinkommens der Vereinten Nationen über den Internationalen Warenkauf und jeglicher Gesetze, die dieses Übereinkommen ausführen und ansonsten anwendbar wären.
(3) Sollte eine oder mehrere Bestimmungen dieses Vertrages unwirksam sein oder werden, so wird sie durch eine gültige Regelung ersetzt, die der gewollten am ehesten entspricht. Die Ungültigkeit einer Bestimmung berührt nicht die Wirksamkeit der übrigen Bestimmungen; diese bleiben wirksam.